Delayed Rewards on S0000 Leaderboards
Resolved
Mar 31, 2026 at 5:12pm UTC
We've identified an issue where Labyrinth and Weekly Event rewards for Genesis shard players were delivered to an internal mailbox that is not visible in-game. S001 shard players were not affected.
We are currently reprocessing rewards for all affected Genesis players.
You do not need to take any action — rewards will appear in your inbox shortly.
We apologize for the delay and thank you for your patience.
Affected services
Created
Mar 31, 2026 at 2:54pm UTC
We're investigating an issue where users on S0000 have had their Leaderboards rewards delayed.
Affected services