Back to overview
Investigating: Equipment & Inbox Issues
Mar 31, 2026 at 7:56pm UTC
Affected services
Production Blue Servers
Resolved
Mar 31, 2026 at 8:26pm UTC
The issue has been resolved. Users still experiencing this should restart their adventures before trying to change equipment.
Affected services
Created
Mar 31, 2026 at 7:56pm UTC
We’re currently investigating an issue where some users are unable to equip items. This may be related to corrupted data blobs.
Additionally, inbox reward claims may be intermittent or fail to process as expected.
Our team is actively working on identifying the root cause and implementing a fix. We’ll provide updates as soon as more information is available.
Thank you for your patience.
Affected services