Back to overview

Investigating: Inbox Issues

Mar 31, 2026 at 11:37pm UTC
Affected services
Production Blue Servers

Resolved
Mar 31, 2026 at 11:37pm UTC

We’re currently investigating an issue where some users are unable to claim inbox rewards.

Our team is actively working on identifying the root cause and implementing a fix. We’ll provide updates as soon as more information is available.

Thank you for your patience.